Unable to Book a room - "Ambiguous user found in the system"
Problem
When trying to Book a room, you get an error "Ambiguous user found in the system" after you log in.
Possible cause:
Did you change your student number since you started as a student at RRU? It may be that the EMS system still tries to validate the old account and not the new account with the new student number.
What to do:
Please contact Computer Services by phone, email or Online Request Form and report that you are getting this error.